Local Exchange UK ver 1.01

To fix a minor bug in version 1.0, Chris MacDonald and myself have now released Local Exchange UK version 1.01 (both as a fresh install and as a patch to our previous version 1.0).

 

See http://www.cxss.org.uk/drupal51/node/62  for change log and more info re our previous version 1.0

See http://www.cxss.org.uk/drupal51/node/58  for change log and more info re our previous version 0.4.0

 

Change log for version 1.01 as follows:

 

/* Local Exchange version 1.01 release notes */

/* 02-02-2010 - changes by Chris Macdonald <chris@cdmweb.co.uk> and Rob Follett <robfol@gmail.com> */
*****************************************************
/* New 1.01 Functionality */
/* ADDITIONAL TWEEKS/CHANGES/BUG FIXES */
[FIX] Moved 'account expiration' settings out of MySQL back into the config file; this resolves a problem re site-sent emails not picking up the defined value of certain variables related to account expiration
*****************************************************
/* FILES Changed */
*includes/inc.config.php:
(): added account expiration settings
*includes/inc.global.php:
(): Updated version number

*****************************************************
/* MySQL Changes/Additions */
*delete from `settings` - MAX_DAYS_INACTIVE, EXPIRATION_WINDOW, DELETE_EXPIRED_AFTER, EXPIRE_INACTIVE_ACCOUNTS

*****************************************************

 

There's a demo version patched to version 1.01 at:

http://letsf.org.uk/localxdemo/

(username and password both "guest" to view site)

Contact me via http://letsf.org.uk/localxdemo if you'd like an account (admin or normal user) to test/view new features.

 

http://falmouthlets.org.uk

is a full working LETS site using many of the new features, and again, is upgraded to version 1.01

 

Latest version of Full and Upgrade versions of Local Exchange UK 1.01 (14th February 2010) as maintained and supported by Chris and myself in collaboration with LLUK are at:

http://letsf.co.uk/downloads/localx-UK-1.01.zip (Full version for fresh install only)

http://letsf.co.uk/downloads/localx-UK-upgrade-1.0-to-1.01.zip (Patch to upgrade ver 1.0 to version 1.01)

 

Please note that for those already running a Local Exchange site, the patch to upgrade to 1.01 *only* works from version 1.0

See http://www.cxss.org.uk/drupal51/node/62 for change log and more info re our previous version 1.0 including link to upgrade to version 1.0 from 0.4.0

See  http://www.cxss.org.uk/drupal51/node/58  for change log and more info re our previous version 0.4.0 including link to upgrade to version 0.4.0 from 0.3.2 (UK version as customised by LLUK)

 

If you don't already have Pear installed on your server or you experience problems, the Pear Libraries as used with the above package are available at:

http://www.letsf.co.uk/downloads/PearLibraries12-2-05.zip

 

All the best,

 

Rob